Renault Captur Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter · #1 ·
Car has been into Lifestyle today they have checked it out there is no fix at the moment but it has been noted and signed as soon as it has been sorted by Renault technical dept they will be fixed, I suggest anybody with this problem get on to their Dealer get it checked out and go on the list to get it sorted, At least Renault now knows that it's not a figment of our imagination we now wait and see what they come up with
 

·
Registered
Joined
·
291 Posts
It's all rather odd really....at least two owners have been advised, supposedly by Renault Technical, that a new instrument panel is required...! and yet here we are with the most recent examination being advised that there is not yet a solution..!.".. No wonder most of us are rather sceptical about Renault Service....
Who does one believe....
 

·
Registered
Joined
·
96 Posts
Discussion Starter · #3 ·
Yes your correct very strange the chap in Lifestyle said if they put a new unit in it will probably have the same fault, in fact thinking about it I might get on to Renault UK and see what they say I will let you know what occurs.
 

·
Registered
Joined
·
291 Posts
Hi...yes I think that is best..... I somehow doubt that a new panel is the correct answer..! Please let us know what Renault Technical say.....if you manage to speak to someone who knows what is going on..!
I still think that it must be some sort of software bug....after all it seems to give correct readings for miles completed and gallons used......so average mpg is only a simple division.... ( that's how I work out mine anyway) ..! Dodgy French calculator...!
 
1 - 4 of 4 Posts
Top