Renault Captur Forums banner

1 - 20 of 228 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
Hoping someone can help me here.

Bought a new diesel Captur at the start of this week. So far done a couple of hundred miles.

Tank was half full when I picked drove it out of the garage, I saw the average MPG sitting at 29.9mpg, but it had done 11 miles, I assume low gear moving around thegarage, onto transportersetc, so wasn't worried. Reset it and drove off.

Found I was getting 29.9mpg on the motorway, though that a bit strange. I reset it and drove extra carefully - 29.9mpg. Tried reset and aggressive driving - 29.9mpg. Found a steep hill, reset it and coasted down the hill - well whaddaya know - 29.9mpg. Tried filling tank full and testing again - 29.9mpg

(I'm resetting it by holding down the button on the stalk until it resets to -.- Tried holding down one and both buttons, I believe holding both resets the trip computer)

I spoke to the salesman back at the garage and he told me I must be wrong, and to give it time. He said it would fluctuate at the beginning of its life, and I accept that, but it isnt fluctuating, it's coming back with the same exact figure, over and over again.

Help please!

p.s. It isn't using up fuel quickly, it appears to be quite economical. Havent used enough to do a calculation at the pumps yet.
 

·
Registered
Joined
·
1,555 Posts
Sounds as if something has gone wrong with the reading...It's impossible to have the same reading coming up over and over again! It's faulty....and needs investigating by the dealer!
 

·
Registered
Joined
·
8 Posts
Captur 1.2 Tce Dynamique S Medianav EDC Grey and black.
I also have this problem I have manually worked out that I am getting around 47 mpg which is not bad for a new engine. I have booked it inon 6th mayalso to have a style pack fitted which was ordered with the car. I hope this is not another R-Link problem, will let you know their findings. Colin
 

·
Registered
Joined
·
1 Posts
Also have the same problem. Dealer tried to tell me it was because its new but had the car for 3 weeks now and no change no matter if i do urban or motorway driving. Has been booked in to be checked out. Please post if anyone has this issue resolved.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #5
Thank you for he replies. Glad to hear I'm not going mad, and not being impatient as the dealer may have hinted at.

I'll get it booked in this week.

I've found if I reset it and drive along in 1st gear, I get the expected low result, say 15mpg. If I go up through the gears it will rise up until it gets to the magic number 29.9, at which point it freezes.

Hopefully the dealer can fix my car's fear of turning 30. I managed, so can it.

btw Colin - got mine with the Style pack, I think it finishes the car off nicely. :)
 

·
Registered
Joined
·
69 Posts
Discussion Starter #6
OK that's it booked in. Waited in vainfor a call back yesterday. Today I got through and was told, "We're very busy. Can you not take it somewhere else?"

It's going in next Thursday.
 

·
Registered
Joined
·
291 Posts
Seems to be a common problem....on mine too.....keep us posted.......
I have tried to email Renault but their website is rubbish..!
 

·
Registered
Joined
·
68 Posts
Mine seems to be stuck on 29.2 MPG, maybe it's building up to the 29.9.

There's no excuse for this problem as this part of the car is old technology. The 10 year old Laguna I traded in when I bought the Captur had exactly the same set up. As far as I can see this isn't linked to the Medianav, if it was then the display would be on the main screen and not the LCD in front of you. I'm interested to see what the outcome is.
 

·
Registered
Joined
·
291 Posts
Please keep us posted.. I've been in touch with Renault customer services but waiting for a call back...! As usual.!
 

·
Registered
Joined
·
69 Posts
Discussion Starter #14
Garage says the captur needs a whole new instrument panel to fix the issue. They have ordered one up and will let me know when it arrives.
 

·
Registered
Joined
·
68 Posts
A whole new instrument panel
Quite a few of us have this problem so there's obviously a bad batch or something. To replace the whole panel seems way over the top.
 

·
Registered
Joined
·
69 Posts
Discussion Starter #16
Well he said they couldn't fix it so would just replace it. Item on back order and they don't know how long it will be before it arrives. Sounds like a popular item........Edited by: Neuro
 

·
Registered
Joined
·
291 Posts
Very interesting.....! Renault customer services !!! emailed me today,in reply to my complaint, to say that they had never come across this problem and suggesting I book in to my local dealer.....
They will get some serious ear bending on phone tomorrow..!
 

·
Registered
Joined
·
291 Posts
Anyone any further news on this problem..?
I have asked Customer services to investigate with Technical dept for possible solution and advise me so that I can go to my dealer with proper advice.. Wait and see !
 

·
Registered
Joined
·
19 Posts
I'd tell them to STOP immediately! Replacing the instrument panel is NOT the answer at this stage!
Renault UK have acknowledged the fault, and are looking into a) what the problem is, and b) how to fix it.

Replacing something which may (or may not) have an inherent fault is going to probably do nothing but inconvenience you.

Call customer services - speak to Kelly!
 

·
Registered
Joined
·
8 Posts
I have taken my car back
for the 29.9 problem this is being looked at by Renault they don't know yet
what is causing this problem and said they would get back to me. Just thought I
would let owners aware that if you have reversing sensors the style pack has to
be factor fitted dealers cannot fit it, I have now had a refund.
 
1 - 20 of 228 Posts
Top