Renault Captur Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
Wondered if anybody has actually been able to add their car onto the MyRenault system ?? I have owned for a month now, but vehicle still doesn't appear? Anyone know how long it takes?






Captur 0.9Tce, Dynamique Media Nav in Metallic Diamond black, with black Explore Wheels, and a Spacesaver I bought afterwards
 

·
Registered
Joined
·
338 Posts
Had to keep trying and in the end got customer service to sort it. And then found that the car was registered as from January 2000. Got sorted in the end
 

·
Registered
Joined
·
97 Posts
I dont understand what are you talking about.My car was in the system at that moment when I finished to write down VIN number. System recognized model of my car and in R-link tab there are all active applications and Packs with info when they expire (Packs).
Are you talking about something different?
 

·
Registered
Joined
·
260 Posts
Not talking about in car Bjs, just the renault website where your car details are stored etc.Edited by: Cj86
 

·
Registered
Joined
·
97 Posts
Yes, I am also talking about website. In my account I have all the details concerning my car and in R-link section (tab) all the details about my applications, etc.screenshot - it is Polish version of website, you can see first page of my applications/products,
 

·
Registered
Joined
·
260 Posts
Thats probably where the problem lies then, the lack of UK customer and technical service updating the databases to make all the info available.Edited by: Cj86
 

·
Registered
Joined
·
335 Posts
I to couldn't register there's an email link on the page. Sent them a email with the data they wanted, 1hr later got an email back saying sorry and I was now on the system.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #10
Thanks for the advice - I found the link - emailed Customer Service, got a response in about 5 minutes !!, and now all details are loaded fine . Guess I should have done that a few weeks ago - thanks again Nick
 

·
Registered
Joined
·
79 Posts
I had the same thing when I tried to register mine after a month - Sent email and got an answer within an hour to say sorry and I was now live on the system
 
1 - 13 of 13 Posts
Top