Renault Captur Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
I got my new captur yesterday and I am going bonkers with the dreadful scraping noise the wipers make! Has anyone else had this or even better has anyone got a solution? Help!
 

·
Registered
Joined
·
924 Posts
Does the noise come from the blades themselves or the motor? If it is the blades there might be a film of wax or some other valeting solution on the windscreen. You could try to clean the windscreen with a little methylated spirit on a cloth. Or vinegar and newspaper, the traditional way to clean glass.
 

·
Registered
Joined
·
38 Posts
Hi bluejay
Sorry to hear your havin a problem with the wipers, mine are quiet, and I forget there on sometimes when they come on on there own on auto, I would pop back to the dealer and. Tell em, possible a mechanic has lent on them and bent an arm maybe cos they shouldn't be scraping after one day, best get it checked.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #4
Okay I will try the vinegar trick tomorrow and the dealer after that. It's definitely the blades doing it, but makes for a very unpleasant drive in the rain right now :(
 

·
Registered
Joined
·
61 Posts
Mine are a bit like that but not all the time. They sometimes drag across the screen. Think it's when there isn't enough water on the screen yet the wipers activate. Edited by: CazB
 

·
Registered
Joined
·
1,555 Posts
Crossbow has the right solution for this I'm sure!! Give the blades a wipe as well! Very frustrating driving with that!!
 

·
Registered
Joined
·
1,555 Posts
How you getting on Bluejay?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #9
I tried the vinegar trick and it has helped, but not fixed it completely so I will try again tomorrow. Got a courtesy call from my dealer yesterday and he said to bring the car back and they will try to sort the problem if I can't do it myself.
 

·
Registered
Joined
·
1,555 Posts
That's reasonable enough...it should be an adjustment and some form of degreaser!!

A bit of a pain that happening...but should be easily solved in the long run.
 
1 - 12 of 12 Posts
Top